Expression Web 4 Tutorials

NO NONSENSE, STRAIGHTFORWARD BOOK FOR BEGINNERS

*CSS & HTML / XHTML

EASY-TO-FOLLOW TUTORIALS
YOU CAN USE TODAY
This is the book I wish I had in front of me when I was getting started with Expression Web. I remember how frustrating it was as a beginner trying to figure out how to use this new web authoring software. The motivation for this book is that frustration. Fueling some of that frustration was the lack of excellent tutorials and resources for beginners.

www.Expression-Web-Tutorial.com
Don’t own Expression web 4? No problem. This Getting Started Guide will work if you own Expression Web 3 or 4.

What makes this a No Non-Sense book? Well, I’ll tell ya what….you’ve likely wasted too much money ($100-$150) on Expression Web Books that claim to be the only book you’ll ever need; or maybe they promise a quick start but leave you wondering if it was really a quick start after all. Or maybe they said step by step from the beginning, yet you end up lost and bewildered by page 3.

I know because I’ve been there too. I have wasted a few hundred bucks on books about Expression Web. None of the books I read started at the beginning. How ‘bout you? Probably not.

I receive emails on a weekly basis from people who have viewed my web site telling me how great it was to finally have found tutorials that actually start from the beginning and progress step by step. They also tell me how they have wasted so much time and money on books that just left them feeling more frustrated.

Congratulations! You’ve just found the book you wished you had purchased right from the beginning. In fact, because I wasted so much money, like so many of you, I decided to write the book I wish I had in front of me when I was getting started with Expression Web.

The book you now hold in your hands will walk you through each step, one by one. The tutorials are clearly spelled out for any beginner to be able to follow. Plus, the numerous video tutorials will solidify the steps and concepts that you need to learn.

When you turn to page 1, you will find a Quick Start Guide and Step 1. There is no introduction and no preface. You will dig in right away and set up a web site and web pages in the first 5 minutes. Now that’s No Non-Sense.
The Purpose of this book: Teach Beginners how to build a web site with Expression Web 4 (or whatever version you own).

How Will You Build A Web Site: You will build your web site with valid XHTML or HTML and CSS.

Who Should Read This Book: Everyone! of course.

Okay, everyone and anyone who wants to learn how to build a web site with Microsoft Expression Web 4.

I am a beginner and never built my own Web Site before. Is this book appropriate for me? Heck yea! This book is written especially for Beginners. You don’t need any web design experience or experience with Expression Web or Dreamweaver.

Listen, I made all the mistakes for you so that you don’t have to. I didn’t have the greatest of resources available to me when Expression Web first hit the market. I did a lot of trial and error. So when I suggest a certain way to do something, it’s because I have already tried it out.

There is not one single tutorial in this book that I have not tested or used myself. This book is really a collection of tutorials that are based upon my experiences and experiments. Yet, it’s not rocket science!!

It’s Not Rocket Science

The key to success in building your own web site is to KEEP IT SIMPLE! I wish the authors before me would have kept their books simple. Sometimes I think an author’s ego takes precedence over meeting the needs of her/his audience. They use big fancy-dancy words and unnecessary high-techno-babble, and as such miss the target.
Of course, not all technology authors put their egos first. There are many excellent books written by excellent authors. Therefore, I will provide you with a list of these books so that you can expand your horizons. You can bet I’ve read each of the books I list. So you should know that you will not be wasting your money on any one of them.

If you did not turn to page 1 by now, then I am in total shock!! Most people skip all this mumbo jumbo. So what are you waiting for!! Dear Lord!

While you are still here...........

Note for Small Businesses

The majority of clients that I work with are Independent Business Owners. As such, I have set up some services to help owners as “situations” arise. The primary service I provide is along the lines of Tutoring & Consulting. But I like to call it Mentoring that you have to pay for. Mentoring is just much more personal, which typifies the kind of interactions I have with many of my clients and students.
1. Keep it Simple.

2. Don’t jump around from one topic to the next. Read one topic before moving on. Many topics are presented in a particular order for a reason.

3. Don’t jump around from this book to the next book.

4. Repetition is Key.

5. Watch the video tutorials as if your life depends upon it.

6. Again, Keep It Simple.

7. Have Fun.

8. Repeat steps 6 & 7
The Game Plan

Know Where you are going before you get there

The plan is to set up an empty web site, make a web page and an external style sheet. Then, you will design your home page. Once your home page is nearly complete with navigation menus and content boxes, etc, we will then save the home page as a Dynamic Web Template. A Dynamic Web Template is a fancy word for Template.

The purpose of using a Dynamic Web Template is to create the rest of our web pages from this template, thus save time by not having to make every web page from scratch. Plus, you can update the template at any time, which in turn will update the pages created from the template. There’s more to it, but just know the game plan ahead of time.

The getting started checklist

1. Set up an empty Web Site
2. Set the Doctype
3. Create a blank Web Page (HTML)
4. Create a blank External Style Sheet (CSS)
   - Link the Style Sheet to the Web Page
5. Style Application Mode: Manual or Auto?
6. Design the Web Page (starting with the Layout)
7. Make a Dynamic Web Template (optional, but highly recommended)
**STEP 1: SET UP AN EMPTY WEB SITE**

1. Click **Site** → Choose **New Site**
2. A Dialog Box Opens [Fig. 1]
3. Make sure **General** is chosen in the left column.
4. Choose **Empty Site** in the middle column.
5. **Name the Web Site**: change the last section of the location and click OK

---

**A Web Site is a Folder created to hold the documents, images, and other page assets that will collectively become a web site.**

---

**FIGURE 1: SET UP WEB SITE**

Example: `...../ExpressionWeb-Online-Class2`
Step 2: Set the Doctype

1. Click Tools → Page Editor Options

2. A dialog box opens. Choose the Authoring Tab
   - Scroll to the middle of the window, and set the Document Type to XHTML 1.0 Transitional by choosing it from the drop down box. (Note: you can use the HTML5 Doctype if you prefer).
   - Choose a Secondary schema that is identical to the Doctype you selected.

3. While we’re here, choose version 2.1 for CSS (W3C Recommendation).

The Doctype can also be established in the next step, Creating Web Pages. I added it as a separate step so as to point out the significance of the Doctype. The Doctype must be set before creating web pages.

Otherwise, you will have to go back and copy and paste a new Doctype into each web page. (See Chapter 2: The Doctype)

Note: The reason I want you to specify XHTML 1.0 Transitional for the Doctype is for the sake of simplicity and so you can follow along with the tutorials. For now, just know that there are very few differences between XHTML and HTML. Plus, the future of XHTML has changed. Instead of XHTML 2, we will have HTML 5. HTML 5 will provide a version of XHTML for those of us who want to keep using it.
**STEP 3: MAKE A BLANK WEB PAGE (.HTML)**

1. Click **File → New → Insert** (See Fig. 2)
   - This will open the **New Page dialog box**.
2. Make sure **General** is chosen in the left column.
3. Choose **HTML** in the middle column.
4. Click **OK**
5. You are now back to the main editing window. Click the **Save** Icon and change the **name of the web page from default to index** and press enter.

*Expression Web will automatically apply the .html or .htm extension for you.*

**FIGURE 2: MAKE NEW WEB PAGE**

**What is the difference between .html and .htm??**

There is no difference between .html and .htm except for one character. In the past, we could only fit in 3 characters, but today we can use all 4. The important thing to remember, is choose one extension and be consistent in using that one extension.

**Note:** the first page of a web site must be named **index.html**, or check with your web hosting provider as they will provide a list of acceptable names for the home page. I have found that default.html as the home page does not always work. (Meaning, when you publish your web site using default.html as the home page, your web site will not show up in a browser.)

If you do not have web hosting right now, no problem, just name your home page ‘index’ to be on the safe side.
We need an external style sheet to hold all the styles we create. This way, we just create most of the styles one time but re-use them repeatedly.

1. Click File → New → click on Page

   This will open the New Page Dialog box just as it did when we created a Web Page (.html).

2. Choose General in the left column.
3. Choose CSS in the middle column.
4. Click OK.

Save it and Name it:

1. In the main editing window, right-click on the untitled_1.css tab --> choose "Save"
2. Name this style sheet main --> press enter.

   Expression Web will automatically add the .css extension to the page name.

** You can name your style sheets anything you would like. For the purposes of this tutorial, name the style sheet as instructed above so that you can follow along.

We now have a web page:  index.html

And an External Style Sheet:  main.css
**Link the Style Sheet to the Web Page**

We need to link the External Style Sheet to the Web Page. All Styles that we create will be stored on the External Style Sheet. We can then link this External Style Sheet to as many web pages as we like. This means we only have to create a style one time, yet we can reuse it repeatedly for all of our web pages.

1. Click on the index.html page tab so that it is open in the main editing window.
2. Now click on the main.css file that is listed in the Folder List Panel and drag it over the index.html page and drop it. This is the fast and easy way to link an External Style Sheet to a web page. (Chapter 4 will show you another method used to link style sheets to web pages.)

**Step 5: Choose the Style Application Mode**

In this step, we must decide how we are going to have Expression Web create our CSS Styles. I highly recommend setting this mode to Manual. All of the tutorials on the DVDs are based upon Manual Mode.

Manual Mode gives us a lot more control over our CSS Styles, yet we can still create auto styles on the fly.

1. Look in the Status Bar at the bottom of the interface.
2. You will see an icon that displays the Letter “M” or the Letter “A”.
3. Be sure the Letter “M” is chosen. (M stands for Manual)

Now you are ready to begin designing your first page.
The next step in our Quick Start Guide, Design the Web Page, will be the topic of discussion for the remainder of this book. Step 6, Saving the Web Page as a Dynamic Web Template will come into play at some point.

**Basically, we will Design one web page for our web site. We will save that one web page as a Dynamic Web Template (DWT) and create the remainder of our web pages from this DWT.**

A Dynamic Web Template is an HTML-based Template used to create more web pages quickly and easily.

Before we talk about DWTs, we have to first create our Web Page Layout, Navigation Menus, Content Areas, and overall ‘look’.

**Please be aware that we cannot create a DWT until we first learn how to Design Web Pages.**